Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Quick question about USB interfaces

Just to keep the suspense going:

Tried to bring the system up to -current (was running an older Beta). Built a new kernel, installed it.

The device now identifies as /dev/uhid3.  Cool - should be able to connect.

Ran the " build" and tried to install userland. Ran into a compile error in 'groff' (as I recall).

Now I'm locked out of the system because PAM is erroring out in a bad library.

I don't need anything except time to get the libraries rebuilt - the good news is that the UPS (which started this whole thread) is now being identified correctly as a uhid device.

Thanks for all your help.

P.S. I also relearned that you don't modify usbdevs.c and usbdev_data.h are built from the usbdevs file - in -current, one of the three DEVICE entries is already in the file (0501). The other two common CyberPower devices are 0005 and 0601.

Dave Burgess
Cynjut Consulting Services, LLC

Home | Main Index | Thread Index | Old Index