Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xen kernel broken for me

I've filled a pr the past month, some of the recently merged branches
broke the dom0 xen kernel, here is the bug report:

Take a look to see if it's related.

Regards, Roger.

2011/7/14 Ben C. <>:
> Couldn't decide if it was more appropriate for ports-xen or
> current-users.  I figured current-users since it's more to do with the
> -current branch than xen, maybe.  I'm not sure, so apologies if anyone
> feels this is in the wrong place.
> on July 9th, I ran cvsup on my src tree, and rebuilt the XEN3-DOM0
> kernel.  At the time I was using a slightly customized kernel
> configuration based on the stock XEN3-DOM0 kernel config.  Mine just
> turned off some debugging and tracing.  The server never came back up
> after rebooting the server with the new kernel and, the majority of
> the events with that are irrelevant at this point.  Eventually, I got
> a hold of some new hardware and have been attempting to install
> XEN3-DOM0 on it for about 2 days.
> I've ran cvsup's on July 9th, 10th, & 11th and essentially the
>     /usr/src/sys/arch/amd64/conf/GENERIC kernel seems working on my
> system, just for a comparison.  It works fine.
>     /usr/src/sys/arch/amd64/conf/XEN3_DOM0-GENERIC kernel is broken.
> I can't provide much debugging information.  All I can tell you is the
> datacenter says "The screen shows a white underscore (_) blinking on
> the screen, and nothing ever happens."
> I backed up the NetBSD src up a bit and June 25th was also showing the
> same behavior.  At this point, I ditched my real hardware (I'm pretty
> sure at this point my datacenter was ready to throw me to the curb
> after 10-15 manual reboots and 3 reinstalls in a matter of days).  I
> setup a NetBSD domu running HVM, and then tried a variety of Xen Dom0
> kernels (under this HVM).  I tracked it down to something between 5/30
> and 6/05 that "broke" my hardware.  I could be wrong, but this seems
> to be the case.
> That is, the kernel that came with the source from 6/05, 6/10, 6/25,
> 6/30, 7/9, 7/10, 7/11 and HEAD as of sometimes about 9AM today, the
> 14th, is non-working for me.  They all have the same behavior as
> mentioend above: GENERIC work, the XEN3-DOM0 kernel does not.  Once
> again, so far all the datacenter techs can tell me is "it shows a
> blinking underscore (_)" and never boots. -- this was all on the i7
> The i5 is running right now on a kernel from 5/30 or so.  I'm waiting
> for the datacenter to reboot my box into the generic kernel again and
> I'm going to test the i7 with the source from 5/30.
> Is anyone else experiencing issues?
> My original hardware was 2.8GHz i5 760 with 8GB of RAM.
> My newer hardware is a 2.93GHz i7 870 with 16GB of RAM.
> Please excuse any ignorance encountered in the above.  Thanks,
> Ben

Home | Main Index | Thread Index | Old Index