Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD vs. Dell XPS 1645 I7-720QM

> On 05/05/10 Patrick Welche wrote:
> On Wed, May 05, 2010 at 07:39:52PM +0930, Berndt Josef Wulf wrote:
>> It was time to replace the old laptop as it became unreliable after four 
>> of hard work. The new laptop arrived a few days ago and naturally I tried 
>> get NetBSD to run on it. The system is a Dell XPS Studio 1645, I7-720QM, 
>> memory, ATI HD4670 1GB and Windows 7 pre-installed. The NTFS partition was 
>> reduced using GParted. Has anyone NetBSD running on this system and if so, 
>> which kernel and configuration was required? NetBSD-5.0.2 doesn't boot and 
>> NetBSD-current makes it to the point of trying to mount the root device. At 
>> this point neither internal nor USB keyboard work. Any help will be very 
>> appreciated.

> So, you e.g. booted your laptop from a NetBSD install CD? Then installed,
> and now on reboot your root device isn't seen? Any chance of the dmesg from
> the install CD? or did you do something else?
> Cheers,
> Patrick

G'day Patrick,

Yes, I booted from a NetBSD install CD. I tried the official 5.0.2 release as 
well as the later iso images I found on the NetBSD repository.

The 5.0.2 release version stops soon after the detection of CPU with the 
following messages:

cpu0 at mainbus0 apid 0: Intel 686-class, 1596MHz, id 0x106e5
fatal protection fault in supervisor mode
trap type 4 code 0 eip c053d35c cs 8 eflags 10202 cr2 0 ilevel 8
kernel: supervisor trap protection fault, code=0
Stopped in pid 0.1 (system) at netbsd:rdmsr+0x4: rdmsr

Using the NetBSD-current image, the boot process will progress to the point 
the kernel wants to looks for the root filesystem, which it fails to find and 
prompting the user to enter its location. At this stage the keyboard doesn't 
work, also it was detected. As mentioned in my previous email, I tried using a 
USB keyboard, but this failed  also.

I've tried again with a snapshot image (5.99.29) and had success. The system 
is currently building binaries from pkgsrc. It took quite some time to 
complete the QT4 packages (12hrs including fetching the packages on the go), 
but it is now well on its way to rip through the KDE4 dependencies. 

Fingers crossed and it will be up and running by tonight.

cheerio Berndt

Home | Main Index | Thread Index | Old Index