Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installation of NetBSD 5.0_STABLE fails when SMP is active

On 10/12/2009 09:39, Martti Kuparinen wrote:
I got two new Dell PowerEdge 2970s (both with two quad-core Opteron CPUs
and 32 GB RAM) and I was trying to install NetBSD/amd64 5.0_STABLE
(built from sources updated yesterday) but installation fails.

First I tried to disable only ACPI but the system hangs before sysinst
starts. Next I tried to disable both ACPI and SMP and it works
correctly. Finally I disabled only SMP and it works too.

So, for some reason SMP does not work on this host. How should I start
to debug this?

I get similar things on my quad core.
It only works if I disable SMP or have a PS2 keyboard plugged in. My symptom is a little different though - only CPU0 fires up, but boot still hangs before it hits init.

Plugging a PS2 keyboard in, or disabling the ps2 keyboard driver in the kernel allows SMP to work without any other issue. I reported this as install/38752 quite some time ago.



Home | Main Index | Thread Index | Old Index