Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: strange networking stack?

Eric Haszlakiewicz wrote:
On Mon, Nov 09, 2009 at 09:44:00AM -0500, Noah McNallie wrote:
I'm not quite sure if the mailing list is the adequate place for this but I can't think of where else to place it that will get the views of anyone that could have an idea what is going on.

I have a sun ultra 30, in my current living situation i don't have an option to make it my nat router, so sadly i'm behind a linksys. I bought a wifi to ethernet bridge to support this configuration. The bridge works fine on my laptop which is opensolaris, though on netbsd (and i just don't understand how it could be related to the os) it will stop bridging packets after a few minutes and will require a steady ping or

does this mean it stops bridging all packets, or just the ones from the
NetBSD machine?
Are both the laptop and the ultra 30 talking over wifi?  i.e.
<laptop>   -----\
                --wifi--- <bridge> ---- ethernet ---- <linksys> --- 'net ---
<ultra 30> -----/

equivalent stream to be sent over it for about 30 seconds until the linksys does (or appears and does) to respond. I put solaris 10 on the ultra 30 and there was no problem with this at all. I feel i've tried everything.

My first thought would be to run tcpdump at various points and see what's
actually getting sent, and see if there's some obvious differences that
jump out at me.  You say you've tried "everything", but it might be helpful
to actually explain in a bit more detail what you've tried.


Right, well I don't have a switch at this house to have such a configuration with the laptop. The laptop has it's own wireless card and I was simply using it as a way to describe how the laptop running opensolaris was capable with this bridge just fine. Though, the bridge is the other way around.
<ultra 30> ----wired---- <bridge> - - - wifi - - - <linksys router>

I have ran tcpdump in the past, though can't currently as I have solaris on the u30, I will work today on getting netbsd back on it. If I remember correctly some strange packets passed by from the linksys (if any) yet it did not respond or route any bridged packets from the u30. I'm curious if it is a compatibility issue between netbsd and the linksys router. I will update this once I have it available.


Home | Main Index | Thread Index | Old Index