Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Recent changes to make breaking tools?

On Fri, 15 Feb 2008, David Holland wrote:

On Fri, Feb 15, 2008 at 04:06:17AM -0800, Paul Goyette wrote:
> I just updated sources a few minutes ago and tried to do a '
> release' for both port-amd64 and port-i386.  In both cases, as soon as
> tried to install an updated copy of texinfo, nbmake dropped
> core.  There doesn't seem to be any symbols around for nbmake (or at
> least I can't find them) but here's the backtrace.

Does the same thing happen if you just fire off nbmake by hand in
texinfo, or does it require being run from If the former,
rebuild nbmake with DBG=-g (or whatever the magic incantation is)...

Yep, it happens even if I just cd to /usr/src/tools/texinfo and issue

        /usr/obj/tooldir/x86_64/amd64/bin/nbmake-amd64 -j4 install

Well, almost the same thing - it doesn't give me a core file.  :(

BTW the bug does not trigger if the -j4 is omitted.

I'll go figure out how to remake make with -g and see what happens.

Home | Main Index | Thread Index | Old Index