tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: AIGLX error: i915 does not export required DRI extension

Le 29/09/12 22:07, Dave Tyson a écrit :
Just doing a bit of testing of NetBSD 6.0_RC2 on an Intel desktop with onboard
I915 graphics.

Pretty much default Xorg,conf (just option to switch keyboard to "gb".  X
complains that  i915 does not export required DRI extension and swaps to
software rendering. Is this easily fixable?  worth a PR ?

dmesg/Xorg logs attached

I guess that recent i915 requires KMS (kernel mode setting) and GEM, and NetBSD does not support them currently. So DRI complains.

In that case I would say that GEM is the missing bit and not KMS (at least for rasterization).

Jean-Yves Migeon

Home | Main Index | Thread Index | Old Index