tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: inconsolata not found

Thomas Klausner wrote:
>I don't know exactly when it started, but a few weeks back my xterm
>switched font. I didn't really think about it then, but today I tried
>to track it down.
>My .Xdefaults has
>XTerm*faceName: Inconsolata
>and I remember that that worked at one point.
>I have pkgsrc/fonts/inconsolata-ttf installed, the package is called
>inconsolata (I'll fix that inconsistency) and
>/usr/pkg/lib/X11/fonts/TTF/Inconsolata.otf exists.
>When I run fc-cache -v, I see:
>/usr/pkg/lib/X11/fonts/TTF: skipping, existing cache is valid: 83 fonts, 0 dirs
>but "xlsfonts | grep -i consolata" comes up empty.
>There is no line for Inconsolata.otf in
>/usr/pkg/lib/X11/fonts/TTF/fonts.dir. It's not a problem with the
>extension, because when I rename make a link for the file to
>Inconsolata.ttf, I still get no entries.

Does your /etc/fonts/fonts.conf file (or local.conf) contain the following
line ?


Recent versions of xterm will use fontconfig.

Robert Swindells

Home | Main Index | Thread Index | Old Index