tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Lua as a scripting language in NetBSD

Thor Lancelot Simon <> writes:

> On Sun, Oct 18, 2009 at 05:50:29PM -0400, der Mouse wrote:
>> >> If people want it they can use it from pkgsrc.
>> > You stanza "If people want it they can use it from pkgsrc" is wrong.
>> > Lua is a language to be embedded.  If I want it in my software, it
>> > has to be in base.
>> Is this because your software will be in base, or is it because you
>> refuse to use pkgsrc - or refuse to use anything not in base - for some
>> other reason?
> pkgsrc is not suitable for embedded systems -- it cannot be cross compiled,
> despite years of effort to the contrary.

If _that_ is the actual problem, then we should try solving it first.
There're some documents on how to use pkgsrc for cross-builds. Perhaps
interested parties should brush them up and report, what should be done
to pkgsrc framework and packages to support cross-builds better.
Obviously, since not all packages can be cross-built, you shouldn't ask
too much.


Home | Main Index | Thread Index | Old Index