tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: factoring out prop_XXX_pack_pref() and prop_XXX_copyin_pref()

On Aug 1, 2009, at 5:01 AM, Christoph Badura wrote:

On Thu, Jul 30, 2009 at 02:34:22PM +0100, Iain Hibbert wrote:
int prop_array_pack_pref(prop_array_t, struct plistref *);
int prop_dictionary_pack_pref(prop_dictionary_t, struct plistref *);

My only comment is that this is getting confusing now, would
prop_*_externalize_to_pref() be more consistent with the already existing
public namespace? (also, prop_*_internalize_from_pref() I guess..)

I really don't care about the names.  I was just extending the already
existing name in what looked to be the obvious proplib way to me.

If people like Iain's naming scheme better, I'm happy to change the names.

I prefer the externalize_to and internalize_from names.



P.S. I think the entire plist internalising/externalising API is extremely
poorly thought out and should be made more general.  Like who thought
that externalising to a path name instead of a file descriptor was the
smartest idea since inventing sliced bread?  But let's not go there.

It was, in fact, thought out. You give it a path name so that it can write to a temporary file in the same directory and then rename to the supplied path, thus ensuring an atomic update of the externalized property list.

-- thorpej

Home | Main Index | Thread Index | Old Index