tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: compat_netbsd32

Dennis den Brok <> schrieb:
> I tried running an i386 userland on top of an amd64 kernel (version
> around 5.99.4x). It seems to work mostly (I only tried single user
> mode); programs like disklabel or ifconfig, though, report errors
> accessing devices. Have I missed something, or is this behaviour
> expected? If so, can it be worked around?

Following up to myself.

It was suggested to me privately that I need device files made for
amd64. As far as I can tell, this means I need an amd64 mknod. It
seems thus practical and, if I knew how, quicker to me to drop a
statically linked amd64 mknod somewhere, but I'm afraid I can't
figure out how to get one using NetBSD's build system... can some-
body help me out on this?

(I'd wish it were possible to just issue something like "./
-m amd64 sbin/mknod"...)

Thanks in advance,

Dennis den Brok

Home | Main Index | Thread Index | Old Index