[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: final steps for reproduceable builds.
christos%zoulas.com@localhost (Christos Zoulas) writes:
> | > 2. the yes or no variable names have MK in front of them typically, the
> | > AR_DFLAG one makes me think I should set it to D or nothing.
> | I know, but it doesn't really seem to fit into the naming scheme very
> | organically. We're not making or not making something based on the
> | flag. The name bothers me too -- both ways.
> Yes, we should come up with a better name. I am of the opinion of having
> on MKDETERMINISTIC tunable for the build.
Fine, but we need something for each component too, and we need a name
for that specifically here -- something that reflects that what we're
dealing with is very specifically the "D" flag to ar on bsd.lib.mk
Any ideas on a name for *that*? I've been unable to think of a good one.
Perry E. Metzger perry%piermont.com@localhost
Main Index |
Thread Index |