[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: final steps for reproduceable builds.
On Mar 10, 12:17pm, perry%piermont.com@localhost ("Perry E. Metzger") wrote:
-- Subject: Re: final steps for reproduceable builds.
| Our old "ar" was not POSIX, but if we ever re-write it to be modern,
| it will need -s anyway, with the stated effects.
| It is true that we may break very old toolchains that are not POSIX
| but I don't see that as a problem. (We also would break toolchains
| that don't supply "D" but one can always set AR_DFLAG to "no" -- the
| other options are all POSIX.)
fine with that part then.
| > 2. the yes or no variable names have MK in front of them typically, the
| > AR_DFLAG one makes me think I should set it to D or nothing.
| I know, but it doesn't really seem to fit into the naming scheme very
| organically. We're not making or not making something based on the
| flag. The name bothers me too -- both ways.
Yes, we should come up with a better name. I am of the opinion of having
on MKDETERMINISTIC tunable for the build.
Main Index |
Thread Index |