tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

[Fwd: [Fwd: Problem with Install Kernel for Kurobox Pro]]

Oops, sorry, wrong address.

-------- Original Message --------
Subject:        [Fwd: Problem with Install Kernel for Kurobox Pro]
Date:   Sat, 06 Dec 2008 09:44:27 -0500
From:   Donald T Hayford <>

I originally sent this to port-arm, but thought this might be a better location. I've built the install kernel for the KUROBOX_PRO (which is currently not supported, but is being worked on by several of the port-arm folk) using the same steps on a Linux box and it boots without a problem. Unfortunately, I need to use Cygwin in general. I tried several different sets of Mr Kiyohara's diff and tar files for the KUROBOX_PRO with the same results. With Cygwin, the normal kernel boots and runs ok. The installation kernels all fail as below. Using Linux, both kernels boot and run correctly. I use the same steps to build for both Cygwin and Linux.

Is there maybe some environment variable I should be setting? Nothing popped out at me.

Any help is greatly appreciated.

Don Hayford

-------- Original Message --------
Subject:        Problem with Install Kernel for Kurobox Pro
Date:   Sun, 30 Nov 2008 09:05:55 -0500
From:   Donald T Hayford <>

I'm trying to build an installation version of the Kurobox Pro kernel and I'm getting a kernel panic when it boots up with a message about a bad directory entry. First bad, reclen=0x10, DIRSIZ=16, namlen=4, flags=0x5001, entryoffsetinblock=50
4, dirblksiz = 512
/: bad dir ino 5 at offset 504: mangled entry
panic: bad dir
Stopped in pid 1.1 (init) at    netbsd:cpu_Debugger+0x4:        bx      r14

The full startup text and a trace are included below. Anybody know what this error is? The installation configuration file (KUROBOX_PRO_INSTALL) looks like:

include "arch/evbarm/conf/KUROBOX_PRO"
no pseudo-device md
include "arch/evbarm/conf/INSTALL"

The reason for removing the pseudo-device md is that it is included in both the KUROBOX_PRO configuration file and in the INSTALL file, so I get an error if I don't remove it first. I'm not using a current version of NetBSD, but a version with a date stamp of 11/07/2008 since that is the latest version of KUROBOX_PRO files that Mr. KIYOHARA has provided.

The normal kernel seems to work fine (but it doesn't use a memory disk). Incidentally, I'm building on a windows XP machine using Cygwin. The build commands are:
$ ./ -O ../obj -T ../tools -m evbarm-el tools
$ ./ -O ../obj -T ../tools -U -u -m evbarm-el distribution
$ ./ -O ../obj -T ../tools -U -u -m evbarm-el -V KERNEL_SETS=KUROBOX_PRO release

Thanks for your help,

-----------------------startup up messages and trace follow-------------------------------------

## Starting application at 0x00008000 ...

NetBSD/evbarm (orion_nas) booting ...
Loaded initial symtab at 0xc04395d0, strtab at 0xc0476568, # entries 15515
pmap_postinit: Allocated 35 static L1 descriptor tables
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
2006, 2007, 2008
The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
The Regents of the University of California.  All rights reserved.

NetBSD 5.99.01 (KUROBOX_PRO_INSTALL) #1: Sun Nov 30 07:38:07 EST 2008
total memory = 128 MB
avail memory = 116 MB
mainbus0 (root)
cpu0 at mainbus0: ARM926EJ-S rev 0 (ARM9EJ-S core)
cpu0: DC enabled IC enabled WB enabled EABT branch prediction enabled
cpu0: 32KB/32B 1-way Instruction cache
cpu0: 32KB/32B 1-way write-back-locking-C Data cache
orion0 at mainbus0: Marvell MV88F5182 SoC Rev. A0 Orion1
orion0: CPU Clock 400.000 MHz  SysClock 200.000 MHz  TClock 166.664 MHz
oriontmr0 at orion0 addr 0xf1020300-0xf10203ff: Marvell Orion Timer
oriongpp0 at orion0 addr 0xf1010100-0xf10101ff: Marvell Orion General Purpose I/
O Port Interface
oriongpp0:   Data Out:                  0x00000000
oriongpp0:   Data Out Enable Control:   0xfc01000d
oriongpp0:   Data Blink Enable:         0x00000000
oriongpp0:   Data In Polarity:          0x00000000
oriongpp0:   Data In:                   0x00000005
oriongpp0:   Data Interrupt Cause:      0x00000008
oriongpp0:   Data Interrupt Mask:       0x00000000
oriongpp0:   Data Interrupt Level Mask: 0x00000000
com0 at orion0 addr 0xf1012000-0xf101201f irq 3: ns16550a, working fifo
com0: console
com1 at orion0 addr 0xf1012100-0xf101211f irq 4: ns16550a, working fifo
mvsata0 at orion0 addr 0xf1080000-0xf1087fff irq 29: Marvell Serial-ATA Host Con
troller (SATAHC)
mvsata0: GenIIe, 1hc, 2port/hc
atabus0 at mvsata0 channel 0
atabus1 at mvsata0 channel 1
ehci0 at orion0 addr 0xf1050000-0xf1051fff irq 17: Marvell Orion USB 2.0 Interfa
usb0 at ehci0: USB revision 2.0
ehci1 at orion0 addr 0xf10a0000-0xf10a1fff irq 12: Marvell Orion USB 2.0 Interfa
usb1 at ehci1: USB revision 2.0
orionpex0 at orion0 addr 0xf1040000-0xf1041fff irq 11: Marvell Orion PCI Express
pci0 at orionpex0
Marvell 88F5182 SoC Orion1 (miscellaneous memory, revision 0x02) at pci0 dev 0 f
unction 0 not configured
oriongbe0 at orion0 addr 0xf1072000-0xf1073fff: Marvell Orion Gigabit Ethernet C
oriongbe0: Ethernet address 00:16:01:a4:e4:87
makphy0 at oriongbe0 phy 8: Marvell 88E1116 Gigabit PHY, rev. 1
makphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FD
X, auto
orioncesa0 at orion0 addr 0xf1090000-0xf109ffff irq 28: Marvell Orion Cryptograp
hic Engines and Security Accelerator
oriontwsi0 at orion0 addr 0xf1011000-0xf101101f irq 5: Orion TWSI controller
iic0 at oriontwsi0: I2C bus
rs5c372rtc0 at iic0 addr 0x32: RICOH RS5C372[AB] Real-time Clock
orionidmac0 at orion0 addr 0xf1060800-0xf1060bff: Marvell Orion IDMA Controller/
XOR Engine
uhub0 at usb0: vendor 0x0000 EHCI root hub, class 9/0, rev 2.00/1.00, addr 1 uhub1 at usb1: vendor 0x0000 EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
mvsata0 port 0: device present, speed: 3.0Gb/s
wd0 at atabus0 drive 0: <WDC WD3200AAKS-75B3A0>
wd0: 298 GB, 620181 cyl, 16 head, 63 sec, 512 bytes/sect x 625142448 sectors
umass0 at uhub0 port 1 configuration 1 interface 0
umass0: USB 2.0 USB Flash Drive, rev 2.00/1.00, addr 2
umass0: using SCSI over Bulk-Only
scsibus0 at umass0: 2 targets, 1 lun per target
sd0 at scsibus0 target 0 lun 0: <USB 2.0, USB Flash Drive, 0.00> disk removable
sd0: 7711 MB, 500 cyl, 8 head, 32 sec, 512 bytes/sect x 15794175 sectors
raidattach: Asked for 8 units
Kernelized RAIDframe activated
Searching for RAID components...
boot device: <unknown>
root on md0a dumps on md0b
mountroot: trying lfs...
mountroot: trying ffs...
root file system type: ffs
First bad, reclen=0x10, DIRSIZ=16, namlen=4, flags=0x5001, entryoffsetinblock=50
4, dirblksiz = 512
/: bad dir ino 5 at offset 504: mangled entry
panic: bad dir
Stopped in pid 1.1 (init) at    netbsd:cpu_Debugger+0x4:        bx      r14
db> trace
    scp=0xc027365c rlv=0xc01d9e28 (netbsd:ufs_dirbad+0x54)
    rsp=0xc26daccc rfp=0xc26dacec
    scp=0xc01d9de4 rlv=0xc01da304 (netbsd:ufs_lookup+0x454)
    rsp=0xc26dacf0 rfp=0xc26dad94
    r6=0xc2f05e18 r5=0x00000010
    scp=0xc01d9ec0 rlv=0xc02bcba4 (netbsd:VOP_LOOKUP+0x38)
    rsp=0xc26dad98 rfp=0xc26dadbc
    r10=0xc26daf4c r9=0x00000000
    r8=0x00000001 r7=0xc26daf24 r6=0xc26daf38 r5=0xc2f03b80
    scp=0xc02bcb7c rlv=0xc02a85cc (netbsd:lookup+0x288)
    rsp=0xc26dadc0 rfp=0xc26dae08
    r5=0xc2f03b80 r4=0x00000000
    scp=0xc02a8354 rlv=0xc02a8cc4 (netbsd:namei+0x16c)
    rsp=0xc26dae0c rfp=0xc26dae88
    r10=0x00000000 r9=0xc04b651c
    r8=0x00000001 r7=0xc26dafb4 r6=0xc082f4cc r5=0xc082f4cc
    scp=0xc02a8b68 rlv=0xc0227958 (netbsd:start_init+0x98)
    rsp=0xc26dae8c rfp=0xc26dafb0
    r10=0x00000000 r9=0xc04b651c
    r8=0x00000001 r7=0xc26dafb4 r6=0xc1dd9d04 r5=0xc082f3e0
    scp=0xc02278d0 rlv=0xc02e8648 (netbsd:lwp_trampoline+0x14)
    rsp=0xc26dafb4 rfp=0xc0846e30
    r10=0x00000000 r9=0xc04b651c
    r8=0x00000001 r7=0xc26dafb4 r6=0x00000000 r5=0xc1dd89e0
Bad frame pointer: 0xc0846e30

Home | Main Index | Thread Index | Old Index