Subject: Re: tar problems in
To: Robert Swindells <>
From: Luke Mewburn <>
List: tech-toolchain
Date: 12/13/2002 12:13:54
On Fri, Dec 13, 2002 at 12:14:52AM +0000, Robert Swindells wrote:
  | Luke Mewburn wrote:
  | >On Thu, Dec 12, 2002 at 08:18:01PM +0000, Robert Swindells wrote:
  | >  | 
  | >  | Is there a description anywhere of what was required to get around the
  | >  | build problems reported back in October when tar was changed to be a
  | >  | link to pax ?
  | >  | 
  | >  | I have got current sources and have rebuilt and installed pax/tar
  | >  | from them, but am still getting the error caused by the empty archive.
  | >It's a bit hard to debug your problem without more details...
  | What more do you want ?
  | I get exactly the same error message as described in the threads started
  | by Rafal Boni and Sean Davis back in October.
  | and

Not being a mind-reader, this extra information would have been useful
as part of your first post ...

As far as I can tell, Rafal posted a followup saying that his problem
had been solved by updating his /usr/bin/tar ...

Personally, I haven't seen this problem, but I probably avoided updating
my /usr/bin/tar during the period that pax-as-tar was broken in a
manner to cause this problem.

Try manually rebuilding bin/pax and reinstalling that, of if you have
no luck there, extracting rescue/tar from a very recent snapshot for your
platform and using that as /usr/bin/tar for the time being.
You can find -current snapshots on