tech-repository archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: hg clone on macOS

Thanks David. I tried the exact same command again today and it selected trunk and everything seems to have worked. Strange for sure that it had selected the ISC branch last time..

On Mon, 13 Aug 2018, David Holland wrote:

On Sun, Aug 12, 2018 at 05:58:09PM -0300, Jared McNeill wrote:
> updating to branch ISC
> abort: case-folding collision between [stuff in bind]
> I assume this is due to case insensitive HFS+. Any easy workarounds?

Yes, it is; try using hg clone -u default so it checks out the trunk.
(Also, by the time you've got this far you've got the clone so you
should now be able to just do hg update -r default.)

If that doesn't work use hg log and pick a version before the bind
update, at least until someone deletes the offending files :-/

Also: it seems broken that the repository conversion has left the tip
on the ISC branch such that this is what hg tries to check out by
default. But maybe you cloned in the middle of the bind update (before
it got merged to head)...

David A. Holland

Home | Main Index | Thread Index | Old Index