tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: R package C++ compile can't find header

On 9/26/18 4:56 PM, wrote:
On Tue, Sep 25, 2018 at 09:02:28PM -0500, Jason Bacon wrote:
On 9/25/18 12:29 PM, wrote:
On Tue, Sep 25, 2018 at 11:07:34AM -0500, Jason Bacon wrote:
Anybody seen an error like this before?  The C++ command appears to be
specifying the correct include path, but reports that it can't find the
header file.

The package is in wip/R-readxl.
I believe I've fixed it, git pull

the wrappers strip out things not in work/.buildink or in
Adding the buildink3 files means it gets added to work/.buildlink.
Yeah, I overlooked the bl3 in Rcpp, but I'm still getting the same error.
Does it build and install for you?  If so, on what platform?

Thanks much,

I am on netbsd-current/amd64. weird, it does build for me.
Problem fixed itself in the new 1.2 release.  Sometimes it pays to procrastinate...

Home | Main Index | Thread Index | Old Index