tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Missing font depenency

On 10/25/18 1:31 AM, wrote:
On Wed, Oct 24, 2018 at 06:02:16PM -0500, Jason Bacon wrote:
Just tried out emacs and gedit on CentOS 7, and both initially showed only
rectangles for menu text.

Installing font-bh-ttf solve the problem for both.

Relevant part of my mk.conf:

X11_TYPE=        modular
PREFER_NATIVE=        no
PREFER_PKGSRC=        yes

I'm guessing systems with the base X11 don't have this issue, but a lot of
packages are probably affected by it when using module X11 and I'm not sure
where the dependency should be listed.

Any suggestions?

It's not just that, it's part of the "default xorg font set" that isn't
very common any more ("modular-xorg-fonts" for us)
It would be nice to make it a dependency, for modular xorg just adding
it as a dependency will be "free".
I have my own custom set of fonts too :-)

Sorry for the slow response, I've been consumed by a major cluster upgrade that I'm just wrapping up now.

Thanks for the input.

I should mention that this is a headless rack-mount server where we run X11 apps over ssh.  It doesn't have a full xorg suite installed, so really the issue is that many X11 applications have some unnamed dependencies on the assumption that xorg is installed.

In reality, xauth is the only common dependency needed on the remote system to run most X11 programs.

Anything else in theory should be somehow flagged as a dependency of each X11-based package, but I don't think it's worth the effort to try and enforce this.  Manually installing xauth + module-xorg-fonts seems sufficient for everything I've tried to far.



Home | Main Index | Thread Index | Old Index