tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Updating plans of lang/ghc

On Wed, Jan 8, 2014 at 2:47 AM, Christos Zoulas <> 
> In article <>,
> PHO  <> wrote:
>>I like the idea of lang/ghc-bootstrap. It is fairly attractive to have
>>a bootstrap kit installed as an usual pkgsrc package. The one thing I
>>am concerning about is that users will have to find and install a
>>binary package if they want to build lang/ghc themselves, otherwise
>>they'll end up standing in front of a circular
>>dependency. pkg_rolling-replace might complain about it each time the
>>packages get updated, even if both lang/ghc-bootstrap and lang/ghc
>>(somewhat old ones) are installed. I'm not sure this is OK or not. On
>>the other hand lang/ghc7 (and wip/ghc) are free from this problem, but
>>their bootstrap kits are somewhat inelegant.
> For those two reasons I think that the only choice is to include the bootstrap
> step inside a single package as part of the build of the final ghc.

I agree.  Building bootstrap binary is more like building "tools" in
NetBSD base.

(I think that pkgsrc should define the build-tools phase, if not exist yet.)

Home | Main Index | Thread Index | Old Index