tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Issues with jabberd2 package 2.3.1

"D'Arcy J.M. Cain" writes:
- On Fri, 13 Dec 2013 10:39:16 -0600
- (Eric Schnoebelen) wrote:
- > Upstream declared that NEWS had replaced the UPGRADING file.
- > So, I'd made the appropriate update.  But you're right, it is
- > more like a Changelog.
- It is also not installed anywhere by the package.

I corrected that a few minutes ago.  The NEWS file is now
installed into /usr/pkg/share/doc/jabberd/.

- > Yes, it does seem to be confusing jabberd2 with jabberd1_4.
- > 
- > Unfortunately, both versions are maintained, and share a common
- > base name.
- We should probably at least remove the TODO item.

Well, there is a seperate package for the 1.4 based version of
jabberd.  I pulled the TODO list item for jabberd 2.3.0 when I

- Are you sure that 1.4 is maintained?  The URL in that Makefile goes to
- a page that is filled with dead links.  I see that there is a jabberd
-  Oddly enough it is under the jabberd14 directory.

No, I can't say I'm sure, only that I recall (in listening in on
the various jabber/xmpp development and admin lists) that
jabberd14 was still being developed, and at version
1.6.<mumble>.  Personally, I've never touched it.

The URL listed in chat/jabberd is definitely incorrect.

FYI: it uses jabberd14 to describe it's lineage, as it is a
distinct code base from jabberd2. jabberd2 is a complete new

Eric Schnoebelen      
    The speed of communications is wondrous to behold. It is also true
      that speed can multiply the distribution of information that 
            we know to be untrue. -- Edward R Murrow (1964)

Home | Main Index | Thread Index | Old Index