tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Perl core modules, corresponding module packages and dependencies


I've marked lang/perl5 as CONFLICTS with p5-* packages older than
Perl-5.18.1 CORE modules, based on `corelist -v 5.18.1'.
It will prevent to install individual Perl module older than CORE modules.

Please take care followings if you have a chance:

1. Notice or fix wrong CONFLICTS pattern.

2. Update p5-* package marked as CONFLICTS with base perl5 package.

3. Fix DEPENDS pattern for CORE modules.

   < DEPENDS+=       p5-File-Temp>=0.19:../../devel/p5-File-Temp
   > DEPENDS+=       {perl>=5.10.1,p5-File-Temp>=0.19}:../../devel/p5-File-Temp

  You can know sufficient perl version with `corelist -a File::Temp'.

4. Add to CONFLICTS of perl5 if you added p5-* package it also in perl CORE.

5. Update CONFLICTS at update lang/perl5.
   `corelist -diff ${PREV_PKGVERSION} ${NEW_PKGVERSION}' will help the job.

OBATA Akio /

Home | Main Index | Thread Index | Old Index