tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Circular dependency errors

* On 2013-08-08 at 07:59 BST, Hauke Fath wrote:

> At 3:01 Uhr +0000 8.8.2013, Paul Ackersviller wrote:
> >> The most common cause is when you don't use an external compiler, and
> >> of course you can't build lang/gcc* without first building its
> >> dependencies, which need a compiler...
> >
> >Not the problem here, as I've never even been able to build gcc from pkgsrc.
> What problems did you run into?
> I tried building gcc4{6,7,8} on OpenIndiana (SunOS 5.11) recently, and for
> all three ran into a weird error where something in the build appeared to
> ascend to lang/gcc??/.. and work through all the subdirectories in lang
> with lots of make errors. The same build on netbsd-6 worked fine.
> Has anybody successfully built lang/gcc?? on SunOS derived OSes recently?

Yes, our SmartOS packages are entirely based on gcc46/gcc47.  I'd
suggest that you simply install my illumos packages:

and use the gcc47 from there to bootstrap your pkgsrc.

Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index