tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Ghostscript seems to be broken on OS X

On 7/20/13 11:40 AM, Adam Ciarciński wrote:
It's the line with the "Times-Roman". Character 5638 is the `E' of "RE".

Am I somehow missing a Times-Bold font?

I posted about this a couple months ago on pkgsrc-users but didn't get 
anywhere. Can anyone reproduce the problem?

Any help would be great.


Seems like NimbusRomNo9L-Regu font is missing.

I tried ghostscript-agpl-9.07nb4 on 10.8.4, but couldn't reproduce the problem. 
But I don't use X11 at all, so maybe that's the issue here.
Could you, please, try "ps2pdf" and see if that produces a valid PDF?

Kind regards,

Ok - I have tracked this down to a problem with freetype2. Ghostscript provides its own but pkgsrc places references to system freetype2 libs in CFLAGS and CPPFLAGS (I'm using XDarwin) as "-I/opt/X11/include/freetype2". This causes a build failure when just building ghostscript without pkgsrc. Building without this produces a working gs.

I can't figure out how that "-I/opt/X11/include/freetype2" is getting in to the CFLAGS in pkgsrc. I tried commenting out the reference to freetype2's No luck there.

How can I get pkgsrc to not put in this include path at configure time? If I can get past that, I should be able to test my theory.


Home | Main Index | Thread Index | Old Index