tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

DEPENDS lines with multiple packages, and old bulk builds (perl)

In doing an (old-style) bulk build, I noticed that p5-Digest-MD5 got
rebuilt, because bulk claimed that the version of a dependency it was
built with did not match the current version.  But, the actual binary
packages were not changed from the previous run.

I think I've tracked this down to

  DEPENDS+=     {perl>=5.7.3,p5-Digest>=1.00}:../../security/p5-Digest

in pkgsrc/security/p5-Digest-MD5/Makefile (still in 2013Q2).

That leads to perl being listed a third time in the pkg_info output:


  Built using:

Looking in doc/pkgsrc.txt, the use of {pkg1>=x,pkg2>=y} is not
described, and the text is quite clear that only a single package
belongs on the left hand side.  If there's a minimum perl version for a
p5-Foo package, fine, but I don't understand why it's related to the
DEPENDS for another module.

I also see this pattern in lang/perl5/

Something is clearly buggy here (because the p5-Digest version is
missing from "Built using", which old-style bulk rightly gets upset
about), but I'm not really sure what the right fix is.  I'd be inclined
to just drop the "perl>=5.7,3," part.

Can anyone explain (and fix doc/pkgsrc.txt please)?

Attachment: pgpLmbaLocmzh.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index