tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

python31 amd64 6.0 binary built without IPv6 support?

I upgraded python31 from 3.1.4 to 3.1.5nb1 using

The build info has:

BUILD_DATE=2012-12-01 23:45:39 +0000
BUILD_HOST=NetBSD amd64-nb6 6.0 NetBSD 6.0 (LIBKVER) #0: Tue Jan 19 00:00:00 UTC
 2038 root@localhost:/sys/arch/amd64/compile/LIBKVER amd64

(I'd like to add some more information to know who built it.)

Some tests that worked previously now fail with:

socket.error: can't use AF_INET6, IPv6 is disabled can't use AF_INET6, IPv6 is disabled

I think the python code has error checking using ENABLE_IPV6. I am 
guessing that when building this package, it didn't detect IPv6 causing 
a bad package to be created.

Can someone check the chroot environment used?

Who built this package?

  Jeremy C. Reed

echo 'EhZ[h ^jjf0%%h[[Zc[Z_W$d[j%Xeeai%ZW[ced#]dk#f[d]k_d%' | \
  tr            '#-~'            '\-.-{'

Home | Main Index | Thread Index | Old Index