tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Impact of updating to tcl/tk 8.5.12, tcl-expect 5.45 with 7 proposed patch sets

On 8/19/2012 08:54, Moritz Wilhelmy wrote:
Hi John,

On Sat, Aug 18, 2012 at 21:42:57 +0200, John Marino wrote:
textproc/tcl-expat v1.1 (no maintainer)
    ltcl84 is hardcoded, this is probably easily fixable.
    Homepage dead, so no new versions available (??)

I think tDOM is more widely used. I started packaging it in wip a while

Hi Moritz,
It was fixed last night (simple patch):

graphics/tkpiechart v5.4 (no maintainer)
    Fails in installation (where it builds), "can't find package stoop"
    Cause unclear, probably resolved in configuration stage

stooop is an object system for Tcl. It's part of tcllib. Can you see if
adding a dependency to tcllib does the trick?

Remember how we got here:
1. It's working currently
2. The message comes after updating tcl84 to tcl85.

The stooop dependency is fine, it's a misleading message.

Anyway, I'd say updating Tcl is important work, thanks for doing this.

A lot of the packages on yesterday's status report have been fix or have more information. I'll post an update shortly. From what I'm seeing, there's no need to keep both tcl84 and tcl85 versions. It's a lot of extra work for little gain.


Home | Main Index | Thread Index | Old Index