tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg-config-0.26

On Wed, 25 Jan 2012 13:12:34 +0900, David Holland 
<> wrote:

On Wed, Jan 25, 2012 at 10:56:27AM +0900, OBATA Akio wrote:
 > >I would prefer not to add more things that depend on glib2 than
 > >necessary, just because rebuilding them after the fairly frequent
 > >glib2 updates is a nuisance. However, things like desktop-file-utils
 > >that end up being runtime deps of many other packages are a much
 > >bigger issue in this regard.
 > We have no experience so frequent glib2 ABI update.
 > Apr 22 2011 2.28.6nb3 from gettext ABI change
 > May 21 2008 2.14.3    switch to external PCRE library
 > Feb 5  2006 2.8.6nb1  from gettext ABI change

Yes, but most update methods insist on recompiling desktop-file-utils
after every glib2 update(*), and then proceed to compile a few other
small packages like wesnoth and gimp.

Are you just talking about pkg_rolling-replace (and `replace' target)?
Yes, it it insufficient and should be fixed instead.
 (I've just killed `pkg_admin set unsafe_depends=YES' locally).

OBATA Akio /

Home | Main Index | Thread Index | Old Index