[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: PKG_FLAVOR renamed to PKG_FORMAT in pkgsrc
From: Ryo ONODERA <ryo_on%yk.rim.or.jp@localhost>, Date: Fri, 21 Oct 2011
21:44:07 +0900 (JST)
> Thanks for great work!
> From: "Jeremy C. Reed" <reed%reedmedia.net@localhost>, Date: Fri, 14 Oct 2011
> 19:29:25 -0500 (CDT)
>> I committed the rename changes of mk/flavor to mk/pkgformat in pkgsrc.
>> This renamed several internal targets.
>> This is from Anton's work on the Google Summer of Code 2011.
>> This should currently have zero change on pkgsrc -- there is only one
>> PKG_FORMAT and it is "pkg" as it was before.
>> Hopefully within the next two weeks I will add the mk/pkgformat/rpm
>> format and maybe the mk/pkgformat/deb (maybe rename to dpkg?) format.
> I think that deb is more preferable than dpkg.
>> I have used the PKG_FORMAT=rpm to use "rpm" to create, install, and
>> deinstall "rpm" packages using pkgsrc to build them.
> By the way, this change breaks pkgtools/verifypc for me.
> Ryo ONODERA // ryo_on%yk.rim.or.jp@localhost
> PGP fingerprint = 82A2 DC91 76E0 A10A 8ABB FD1B F404 27FA C7D1 15F3
Main Index |
Thread Index |