[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
PKG_FLAVOR renamed to PKG_FORMAT in pkgsrc
I committed the rename changes of mk/flavor to mk/pkgformat in pkgsrc.
This renamed several internal targets.
This is from Anton's work on the Google Summer of Code 2011.
This should currently have zero change on pkgsrc -- there is only one
PKG_FORMAT and it is "pkg" as it was before.
Hopefully within the next two weeks I will add the mk/pkgformat/rpm
format and maybe the mk/pkgformat/deb (maybe rename to dpkg?) format.
I have used the PKG_FORMAT=rpm to use "rpm" to create, install, and
deinstall "rpm" packages using pkgsrc to build them.
Jeremy C. Reed
Main Index |
Thread Index |