tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg-config-0.26 depends on glib2

On Thu, Jul 14, 2011 at 16:00:37 +0200, Joerg Sonnenberger wrote:
> Fill a bug upstream and don't update. I don't see much point in that
> anyway. Maybe it is time to write a clean C version of it...

A clean, BSD licensed version of pkg-config in portable C without external
dependencies (i.e. no glib) sounds reasonable to me.
Apparently, after looking at the little amount of code pkg-config actually is,
and considering what it does (nothing terribly hard, it seems), this task is
probably not going to be terribly hard, even without glib.

Was that what you had in mind?


Home | Main Index | Thread Index | Old Index