tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg-config-0.26 depends on glib2

On Thursday, at 16:00, Joerg Sonnenberger wrote:
| On Thu, Jul 14, 2011 at 03:21:49PM +0200, Thomas Klausner wrote:
| > pkg-config-0.26 has removed its internal copy of glib1.
| > Now it uses glib2.
| > 
| > This poses a chicken-and-egg problem, since glib2 needs pkg-config to
| > build and thus the dependency tree has a circle.
| Fill a bug upstream and don't update. I don't see much point in that
| anyway. Maybe it is time to write a clean C version of it...

Looks like they are aware of it already, and not willing to change their
mind... See:

They mention an interesting hint for invoking glib2 configure:
$ ZLIB_CFLAGS= ZLIB_LIBZ=-l ./configure --with-pcre=internal

HTH :)

Home | Main Index | Thread Index | Old Index