tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: which version of GNU bison is required?

On Sat, May 14, 2011 at 10:59:18PM +0200, Georg Schwarz wrote:
 > Which is the least version of GNU bison that pkgsrc expects?
 > In there's a comment
 > "# Darwin's bison is too old (1.28)."
 > On MacOS 10.6 bison is 2.3. Is that sufficient?
 > Could anyone provide that information of previous releases of MacOS?

I don't know, but my guess is that it's fine. The changelog says

   Darwin's bison is too old (1.28) to build some packages
   (e.g. libgnomeprint).  Comment out lines for the native bison
   and note why.

but that's from 2006.

would be nice if the tools framework had version dependency info like
builtin handling does/can... probably not trivial though.

David A. Holland

Home | Main Index | Thread Index | Old Index