tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [ pkgsrc NetBSD 5.1_RC3/x86_64 2010-09-26 14:38]

On Oct 2, 2010, at 3:43 PM, Joerg Sonnenberger wrote:

> On Sat, Oct 02, 2010 at 03:38:36PM -0700, Min Sik Kim wrote:
>>  % cd devel/lua-mode
>>  % make show-depens
>>  emacs>=23:../../editors/emacs
>> If "show-depends" says this package depends on editors/emacs, then the
>> bulk build must make sure this package depends on editors/emacs, not on
>> an arbitrary later version such as editors/emacs-snapshot.
> It is not an arbitrarty later version. It is the best matching version
> for the dependency. If it wanted to have Emacs 23, it should say so. It
> doesn't.

If this were the case where we picked up the best binary package among those 
already available, you would be right.  But in this bulk build, there's no 
binary package for emacs-snapshot and the package does say it depends on 
editors/emacs.  So I don't think there is any reason to stop building elisp 

Min Sik Kim

Home | Main Index | Thread Index | Old Index