tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: anyone using pkgsrc with NetBSD<1.5?

At 0:47 Uhr +0100 28.2.2010, Alistair Crooks wrote:
>> There are probably bigger obstacles than user(8) to deploying current on
>> old NetBSD versions... still, what about other target platforms? Does A/UX
>> ship with a compatible user(8)?
>we have pkgsrc/sysutils/user_darwin for darwin, don't know yet about
>a/ux, but user(8) itself includes some bsd-specific things, like
>pwd_mkdb, so it wouldn't just be a compile and run replacement.

Ah, okay - I hadn't thought of the intricacies of shadow password
implementation. Something that 4.4BSD got right early up, I guess, while
others were dragging their feet.

What would be the cost of keeping user(8), then, as opposed to point the
three remaining users to cvs attic, or dropping a
netbsd_pre_1_5_user_src.tar.gz somewhere on where nobody
will find it?


"It's never straight up and down"     (DEVO)

Home | Main Index | Thread Index | Old Index