tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

buildlink dependencies for libgnomecanvasmm and gtkmm

graphics/libgnomecanvasmm/ includes

which has:

# increase API_DEPENDS as a hack because now depends on pangomm
BUILDLINK_API_DEPENDS.gtkmm+=   gtkmm>=2.18.2

Ignore that old comment -- it was from me and is no longer applicable 
since it has been bumped since then.

But I have libgnomecanvasmm-2.26.0nb1 installed which requires 
gtkmm>=2.14.1. My installed gtkmm-2.16.0 is good enough.

So the buildlinking fails when I build something that includes 

===> Creating toolchain wrappers for gtkpod-0.99.14nb2
ERROR: gtkmm>=2.18.2 is not installed; can't buildlink files.
*** Error code 1

This similar to

Home | Main Index | Thread Index | Old Index