tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cpp in OS X, information needed

On Sun, Dec 20, 2009 at 1:16 PM, Georg Schwarz 
<> wrote:
> Am 20.12.2009 um 13:21 schrieb Julio Merino:
>> Also, the question is: what versions of OS X do we care about?  Are we
>> really interested in supporting the ancient toolchain that may be in,
>> e.g. OS X 10.2?
> as always, the answer IMHO depends on the cost involved. If it's just a
> simple, transparent .if .else, then why not.

Well, yes and no.  If we change the default conditionally, we add
complexity for no real gain (unless someone steps up and tests that
things still work in ancient versions).  Plus, if we are going to use
this change to fix libtool (instead of my workaround in f2c), we'd be
leaving out old OS X versions broken anyway, thus only fixing part of
the problem.

Julio Merino

Home | Main Index | Thread Index | Old Index