tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: handle modular-xorg-server upgrade and "module requirement mismatch" and adding CONFLICTS for old modules?

On Wed, Jun 17, 2009 at 05:15:41PM -0500, Jeremy C. Reed wrote:
> On Wed, 17 Jun 2009, Joerg Sonnenberger wrote:
> > On Tue, Jun 16, 2009 at 01:02:17PM -0500, Jeremy C. Reed wrote:
> > > I think maybe a conflicts should be added also to modular-xorg-server for 
> > > the ones that conflict.
> > 
> > No. We don't add conflicts for shared libraries either.
> Sure seems like I have CONFLICTS for reasons like ths before.

Name three cases.

> So what is the alternative? What keeps a pkgsrc user (not a pkgsrc 
> developer) from making this easy mistake of installing incompatible 
> packages?

Why is this case special? It is just like a major version bump. Do a
full update or none at all.


Home | Main Index | Thread Index | Old Index