I really don't like the name PKGSRC_LICENSES, since these are *not* the licenses pkgsrc is distributed under, which is what I would expect a variable of that name to hold. Good point. Also, I don't see your problem with ACCEPTABLE_LICENSES: These are the licenses that are acceptable for packages installed on my system. My problem is 85% that it has led repeatedly to people writing 'the user accepts the license' and 'to accept the license', etc. Stating clearly in the documentation that setting this variable does not in itself constitute the acceptance of any license (after all, it's not called ACCEPTED_LICENSES) and that TNF and pkgsrc are not facilitating the formation of a contract sounds like a good idea. Sure, that would help, but the remaining 15% is how this would be interpreted by outsiders. I would like to get rid of anything that looks like "ACCEPT". Perhaps LICENSES_PERMITTED? Just LICENSES seems prone to error. I'll see if I can think of a better variable name. As for Thomas's comment about a flag day, we can use the old words for a while, similar to how LICENCE is interpreted.
Description: PGP signature