tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Licence handling: next steps (with attachment)

In article <> Thomas wrote:
: > I really would like to change all the language surrounding
: > ACCEPTABLE_LICENSES to be more mechanical and less sounding like pkgsrc
: > is helping to form contracts.  The essence would be to chagne
: > ACCEPTABLE_LICENSES to PKGSRC_LICENSES, and no longer say 'the user has
: > accepted' but instead 'the user has instructed pkgsrc to build software
: > with this set of licenses'.  (The user may in fact be an employee and
: > have not accepted anything, and generally this is messy.)
: > 
: >   ${PKGNAME} has a license ${LICENSE} not in PKGSRC_LICENSES.
: >   To view it, enter \"${MAKE} show-license\"." \
: >   To instruct pkgsrc to build software with ${LICENSE},
: >   add this line to ${MAKECONF}:
: > 
: > Then, we replace _ACCEPTABLE with _LICENSE_CHECKED.

: So basically:

  I really don't like the name PKGSRC_LICENSES, since these are *not*
the licenses pkgsrc is distributed under, which is what I would expect
a variable of that name to hold.

  Also, I don't see your problem with ACCEPTABLE_LICENSES: These are
the licenses that are acceptable for packages installed on my system.

  Stating clearly in the documentation that setting this variable does
not in itself constitute the acceptance of any license (after all,
it's not called ACCEPTED_LICENSES) and that TNF and pkgsrc are not
facilitating the formation of a contract sounds like a good idea.


Home | Main Index | Thread Index | Old Index