tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: already installed?

On Thu, Mar 19, 2009 at 10:53:43AM -0700, Aaron J. Grier wrote:
>       ===> Installing for foobar-5.0nb2
>       ERROR: foobar-5.0nb2 is already installed - perhaps an older version?
>       ERROR: If so, you may use either of:
> Dear pkgsrc,
>       thank you for letting me know this.  I just wish you could tell
> me before I've spent the time extracting, patching, buildlinking, and
> compiling.  could you please let me know this before you start the
> process?  it would save me quite a bit of time.  thanks.

And this is a good part to do it like it is currently handled.
That saves one to deinstall a working package and leaves you without
it if the build fails.


Home | Main Index | Thread Index | Old Index