tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: BUILDLINK_API_DEPENDS can be harmful

This usage of BUILDLINK_API_DEPENDS.pixman+=pixman>=0.12.0 is not good.
It should not be defined statically, should be taken from installed cairo 
package like build options.
If installed cairo is depend on pixman>=0.11.0, should be defined as
BUILDLINK_API_DEPENDS.pixman+=  pixman>=0.11.0
or installed cairo is not build with builtin pixman, should be defined as
USE_BUILTIN.pixman=     no

not a job for individual packages...

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index