tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ERROR: cairo is not installed; can't buildlink files.

===> Creating toolchain wrappers for gnash-0.8.2nb1
ERROR: cairo is not installed; can't buildlink files.
*** Error code 1

Default options. So uses gtk2 which has
BUILDLINK_API_DEPENDS.gtk2+=    gtk2+>=2.4.0
BUILDLINK_ABI_DEPENDS.gtk2+=    gtk2+>=2.8.17nb1
(I am ignoring the ABI depends.)

It uses cairo which has
BUILDLINK_API_DEPENDS.cairo+=   cairo>=1.6.4
BUILDLINK_ABI_DEPENDS.cairo?=   cairo>=1.0.4nb1
(I am also ignoring the ABI dependency.)

I have installed:

gtk2+-2.12.0nb1 (installed Sep 19 2007)

cairo-1.4.10 (installed Sep 19 2007)

So since my gtk2+ is good enough, it never needs to update the cairo. The 
cairo is not good enough so it is not buildlinked.

That was from upgrade from cairo-1.4.14 and added dependency on pixman.

The pkgsrc Guide says:

 "In some cases, the packages that depend on this new version may need 
their PKGREVISIONs increased and, if they have files, their 
BUILDLINK_API_DEPENDS.pkg adjusted, too. This is needed so pkgsrc will 
require the correct package dependency and not settle for an older one 
when building the source."

The error "ERROR: cairo is not installed; can't buildlink file" is 
misleading. This should be fixed. It should not ignore second-level (or 

  Jeremy C. Reed

p.s. I was thinking this was related to PR #38785. But maybe not.

Home | Main Index | Thread Index | Old Index