tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

OpenSolaris bootstrap problems


while trying to bootstrap pkgsrc on Opensolaris 2008.05 (x86, using
sunpro compiler), I ran into a series of problems:

- SUNWhea and SUNWscp need to be installed.

- Sunpro does not support -Dfoo(x)=XXX on command line (it defines foo
  to 1 and ignores the rest).  This makes pdksh fail to build, as it
  tries to define __RCSID(x) and __UNCONST(x) on the command line.

- bootstrap --compiler=sunpro fails to set CC, thus trying to build
  awk using gcc.  (bootstrap correctly guesses sunpro as compiler and
  in that case also correctly sets CC).

  (I've worked around all of the above.)

- Installing dependencies of pkg_install fail as follows:

===> Installing dependencies for pkg_install-20080423
 not found
=> Full dependency tnftp-[0-9]*: NOT found
=> Verifying reinstall for ../../net/tnftp
 not found
ERROR: [] A package matching ``tnftp-[0-9]*'' should
ERROR:     be installed, but one cannot be found.  Perhaps there is a
ERROR:     stale work directory for ../../net/tnftp?
*** Error code 1

  This one, however, has me stumped.  How is this supposed to work?
Or is bootstrap simply broken currently?


Home | Main Index | Thread Index | Old Index