tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Handling newer msgfmt files in NetBSD

On Thu, 06 Mar 2008, David Brownlee wrote:
>       As of at least NetBSD-4.0 the shipped gettext cannot handle newer
>       .po files which use context and fuzzy matches features.
>       For wip/ktorrent3 I wrote a nasty little awk script which
>       just strips out those entries, which gets us a build.
>       Does anyone have any thoughts as to the best way to resolve this?

I've been meaning to ask the same question as it effects the .po files 
in all of KDE4.    "msgctxt" is a feature of gnu gettext 0.15 so even 
the current pkgsrc gettext package (which is 0.14.6) doesn't support 


Home | Main Index | Thread Index | Old Index