tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: x11/openmotif broken?

On Tue, Jan 08, 2008 at 10:21:01AM +1100, Malcolm Herbert wrote:
|On Mon, Jan 07, 2008 at 01:36:38PM +0100, Joerg Sonnenberger wrote:
||On Mon, Jan 07, 2008 at 03:39:33PM +1100, Malcolm Herbert wrote:
||> Where would X11/bitmaps/gray live normally? is that something that
||> should be on the system already or is it missing from the build area
||> for some unspecified reason?
||It is part of xbase.
|ah, so for compiling X11 stuff one needs xbase as well as xcomp ...
|right ... OK, ta

actually, no, I have /usr/X11R6/include/X11/bitmaps/gray and it seems
to have actual content:

|# find /usr/X11R6 -name gray
|# cat /usr/X11R6/include/X11/bitmaps/gray
|#define gray_width 2
|#define gray_height 2
|static char gray_bits[] = {
|   0x01, 0x02};

I'd built this pkgsrc compiling chroot area by unpacking the sets into a
directory tree with tar -zxvpf - after your suggestion I made sure I'd
unpacked xbase again and then to be sure perms and symlinks links were
OK I even ran the mtree specs from /etc/mtree/* over it too ...

I still get the same error when compiling x11/openmotif though ...

stumped ... x11/qt3-tools also fails to link, but I'll concentrate on
one problem at a time I think ... :)

Malcolm Herbert                                This brain intentionally                                                left 

Home | Main Index | Thread Index | Old Index