Subject: Re: CVS commit: pkgsrc/print/scribus
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 08/14/2004 15:56:46
Thank you for updating scribus.

I had also had an updated version in my pkgsrc that I used under Linux.

What platform did you test it under?

It does not work under NetBSD 1.6.2. The build fails because default
compiler is out-of-date. Forcing it to use gcc 3 also does not work,
because dependencies (like QT libraries) also have to be built with gcc3.

Thomas suggested that we have two scribus packages (but I never did that

Maybe we should mark the current package as not for NetBSD 1.6.2?

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links

p.s. The error I got under NetBSD 1.6.2 STABLE is

 g++ -DHAVE_CONFIG_H -I. -I../../..
-I/usr/pkg/qt3/include -I../../../scribus -DQT_THREAD_SUPPORT
-O2 -O2 -s -fno-exceptions -fno-check-new -c export.cpp
-Wp,-MD,.deps/export.TPlo  -fPIC -DPIC -o .libs/export.o
export.cpp: In method `bool ExportBitmap::exportPage(unsigned int, bool =
export.cpp:119: ambiguous overload for `bool ? int : QString'
export.cpp:119: candidates are: operator ?:(bool, QString, QString) <builtin>
export.cpp:119:                 operator ?:(bool, const char *, const char
*) <builtin>
gmake[5]: *** [export.lo] Error 1
gmake[5]: Leaving directory