tech-perform archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: WAPL/RAIDframe performance problems

> My testing has lead to some questions
Could you post some figures? For instance, what's the file system throughput 
to the raw disc versus a two-component Level 1 RAID (with stripe size equals 
file system block size)?

> I think it's possible, even if you have the raid card in jbod mode,
I don't know of any other modes the card (3081E-R) has.

> Is it possible for you to set up a test with raid5 using a different sata 
> or sas interface card?
Difficult. I don't have any other machine with SAS (except one identical to 
the to-be file server minus the data discs). I could try a desktop machine 
with two or three SATA drives attached to the mainboard.

> I've found that for high work loads this card just stops generating 
> interrupts for no apparent reason.
> I wonder if you're suffering from a similar, but not quite so fatal, kind of
> issue with your raid controller?
How can I check that?

> while the spsu size was right, the sector boundaries which defined the
> stripe might not be the same as the blocks being read from and written to
> on the filesystem itself.
I seriously hope that's not true.
I think if the partition is aligned, the file system blocks are aligned.
Can some file system expert please comment on this?

> raid5 will always be slower than raid1
Why? If the stripe size equals the fs block size, I don't see why that should 
be the case.

> I kno[w] how frustrating it can be to try and figure out why something isn't 
> working as expected.
Yes. Of course, that's my job, but it gets frustrating after weeks without 
clues of improvement.

Home | Main Index | Thread Index | Old Index