tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Using multiple interfaces (3+) causes intermittent system freezes on NetBSD 5.1_STABLE and later... [was: NetBSD 5 partly freezing, may be related to 802.1Q]

On Jun 9, 2012, at 14:06 , iMil wrote:
>> I'm not sure if we got any wiser...
>> btw. did you have three different IP-networks connect before you started 
>> using .1Q? (If not, can you try do the same thing without VLAN tagging?)
>> As you mentioned earlier, another way to go is to upgrade to 6.0_BETA2 to 
>> see if the problem still exists...
> This gateway used to have 3 NICs, each one of them being connected to its
> dedicated network. I am absolulely not sure the issue is related to vlan
> tagging, it's just a wild guess...
> Difficulty here is also the freeze occurs very really randomly, it can
> happen within an hour, a day or sometimes more.

So, back to this again.

Before I went on holiday I removed 2 of the 3 interfaces on the system I 
noticed this problem on, and now it has been stable since (~2 months). So I 
don't think it's VLAN tagging problem, I think it's a "multiple interfaces" 
problem... For us this also occurred after installing something later than 
"NetBSD 5.1 RELEASE" (which also matched your perception), and AFAIK it's still 
present in NetBSD 6.0 BETA... (don't know about -current...)

I haven't found any suitable PR for this problem, so maybe you or I should file 
The sad thing is that we can't get any valuable debugging information, as the 
system becomes unresponsive...


Attachment: smime.p7s
Description: S/MIME cryptographic signature

Home | Main Index | Thread Index | Old Index