tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: IWN driver (5000 & 5100 series)

I tried your patch. I am on amd64 and had to patch a little due to:

../../../../dev/pci/if_iwn.c: In function 'iwn_set_timing':
../../../../dev/pci/if_iwn.c:3367: warning: format '%llu' expects type 
'long long unsigned int', but argument 3 has type '__uint64_t'
../../../../dev/pci/if_iwn.c: In function 'iwn_read_firmware':
../../../../dev/pci/if_iwn.c:5178: warning: format '%d' expects type 
'int', but argument 3 has type 'size_t'

I used PRIu64

        DPRINTF(("timing bintval=%u, tstamp=%" PRIu64", init=%u\n",
            ni->ni_intval, le64toh(cmd.tstamp), (uint32_t)(val - mod)));
and %zd

                    "firmware file too short: %zd bytes\n", size);

hopefully that is correct.

I rebooted with new 5.0_RC3 but didn't see any change.

        vendor 0x8086 product 0x4232 (miscellaneous network) at pci2 dev 0 
        function 0 not configured

I rebooted again (with the switch on front of laptop turned to on and that 
made a light come on for the wireless) but still no change.

No extra device showed with "ifconfig -l".

Why is the pci_matchid list not used with "#if 0"? Why isn't the 
PCI_PRODUCT_INTEL_PRO_WL_5100AGN_1 et cetera in the pcidevices? Is that 
not needed?

(I added it to my pcidevs and regenerated pcidevs.h but then realized 
maybe it is not used so didn't rebuild, install, and reboot yet.)

Note I didn't install any firmware yet, but didn't see any kernel output 
about that.

Home | Main Index | Thread Index | Old Index