tech-multimedia archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [ uvideo crashes 5.0_RC1 / i386]

Rafal Boni wrote:
 > Seen on my old P3 SMP machine -- I was trying to get a new QuickCam
> Communicate Deluxe working under NetBSD, and so far I'm batting 0...
> 'cheese' can't open it; even through gstreamer-properties seems to be
> able to (well, the test runs, I get no picture).  I built ekiga, and
> that seems to have the same bad luck, but I haven't tried it on the
> local display yet -- only remotely, so maybe it's something about the
> Cygwin X server I was using for a display.
> So out of desperation I tried to feed /dev/video0 to 'mplayer', and
> was rewarded with the machine crashing, see the picture below --
> Any ideas?  Known issue? Should I PR it?
> --rafal

According to Logitechs website this is a high-speed usb2 webcam, and
from your dmesg uvideo is attaching at a full-speed usb1.1 host controller.

What's _probably_ happening is uvideo allocating hundreds of xfers and
feeding them to uhci, which internally limits itself to 128 xfers at a
time, and that leads to some memory corruption. This has caused a panic
for at least one person in the past [0].

To confirm this, could you re-build the kernel with options DIAGNOSTIC
enabled? If the above is correct, you should see a couple of
"uhci_device_isoc_enter: overflow!" lines before it panics.



Attachment: signature.asc
Description: OpenPGP digital signature

Home | Main Index | Thread Index | Old Index